const regex = /^(?<prefixNr>.*)-(?<type>FE)-(?<suffixNr>.*)\.(?<ext>xml)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?<prefixNr>.*)-(?<type>FE)-(?<suffixNr>.*)\\.(?<ext>xml)$', 'gm')
const str = `003101172267-FE-00100001010001679522.xml
003101172267-MH-00100001010001679522.xml
003101172267-FE-00100001010001679522.PDF
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}