import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?<prefixNr>.*)-(?<type>FE)-(?<suffixNr>.*)\\.(?<ext>xml)$";
final String string = "003101172267-FE-00100001010001679522.xml\n"
+ "003101172267-MH-00100001010001679522.xml\n"
+ "003101172267-FE-00100001010001679522.PDF\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}