import re
regex = re.compile(r"^(?<prefixNr>.*)-(?<type>FE)-(?<suffixNr>.*)\.(?<ext>xml)$", flags=re.MULTILINE)
test_str = ("003101172267-FE-00100001010001679522.xml\n"
"003101172267-MH-00100001010001679522.xml\n"
"003101172267-FE-00100001010001679522.PDF\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")