$re = '/^(?<prefixNr>.*)-(?<type>FE)-(?<suffixNr>.*)\.(?<ext>xml)$/m';
$str = '003101172267-FE-00100001010001679522.xml
003101172267-MH-00100001010001679522.xml
003101172267-FE-00100001010001679522.PDF
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);