using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<h3 class=\""suite-title\"">author</h3>\s+<ul class=\""suite-title-list\"">\s+<li class=\""suite-title\"">\s+<a href.*\"">(.*?)</a>";
string input = @"Hi
I have the following code. How do I separate the `name2` and `name3` from the `""suite-title"">author</h3>` field with regex?
<li class=""suite-item"">
<h3 class=""suite-title"">thinker</h3>
<ul class=""suite-title-list"">
<li class=""suite-title"">
<a href=""https://www.sitename.org/profile/name1/fl/suite"" title=""name1""class=""suite-name"">name1</a>
</li>
</ul>
</li>
<li class=""suite-item"">
<h3 class=""suite-title"">author</h3>
<ul class=""suite-title-list"">
<li class=""suite-title"">
<a href=""https://www.sitename.org/profile/name2/fl/suite"" title=""name2""class=""suite-name"">name2</a>
</li>
<li class=""suite-title"">
<a href=""https://www.sitename.org/profile/name3/fl/suite"" title=""name3""class=""suite-name"">name3</a>
</li>
</ul>
<h3 class=\""suite-title\"">author</h3>\s+<ul class=\""suite-title-list\"">\s+<li class=\""suite-title\"">\s+<a href.*\"">(.*?)</a>
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}