# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"<h3 class=\"suite-title\">author</h3>\s+<ul class=\"suite-title-list\">\s+<li class=\"suite-title\">\s+<a href.*\">(.*?)</a>"
test_str = ("Hi\n"
"I have the following code. How do I separate the `name2` and `name3` from the `\"suite-title\">author</h3>` field with regex?\n\n"
" <li class=\"suite-item\">\n"
" <h3 class=\"suite-title\">thinker</h3>\n"
" <ul class=\"suite-title-list\">\n"
" <li class=\"suite-title\">\n"
" <a href=\"https://www.sitename.org/profile/name1/fl/suite\" title=\"name1\"class=\"suite-name\">name1</a>\n"
" </li>\n"
" </ul>\n"
" </li>\n"
" <li class=\"suite-item\">\n"
" <h3 class=\"suite-title\">author</h3>\n"
" <ul class=\"suite-title-list\">\n"
" <li class=\"suite-title\">\n"
" <a href=\"https://www.sitename.org/profile/name2/fl/suite\" title=\"name2\"class=\"suite-name\">name2</a>\n"
" </li>\n"
" <li class=\"suite-title\">\n"
" <a href=\"https://www.sitename.org/profile/name3/fl/suite\" title=\"name3\"class=\"suite-name\">name3</a>\n"
" </li>\n"
" </ul>\n\n\n"
" <h3 class=\\\"suite-title\\\">author</h3>\\s+<ul class=\\\"suite-title-list\\\">\\s+<li class=\\\"suite-title\\\">\\s+<a href.*\\\">(.*?)</a>\n\n\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.