import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<h3 class=\\\"suite-title\\\">author</h3>\\s+<ul class=\\\"suite-title-list\\\">\\s+<li class=\\\"suite-title\\\">\\s+<a href.*\\\">(.*?)</a>";
final String string = "Hi\n"
+ "I have the following code. How do I separate the `name2` and `name3` from the `\"suite-title\">author</h3>` field with regex?\n\n"
+ " <li class=\"suite-item\">\n"
+ " <h3 class=\"suite-title\">thinker</h3>\n"
+ " <ul class=\"suite-title-list\">\n"
+ " <li class=\"suite-title\">\n"
+ " <a href=\"https://www.sitename.org/profile/name1/fl/suite\" title=\"name1\"class=\"suite-name\">name1</a>\n"
+ " </li>\n"
+ " </ul>\n"
+ " </li>\n"
+ " <li class=\"suite-item\">\n"
+ " <h3 class=\"suite-title\">author</h3>\n"
+ " <ul class=\"suite-title-list\">\n"
+ " <li class=\"suite-title\">\n"
+ " <a href=\"https://www.sitename.org/profile/name2/fl/suite\" title=\"name2\"class=\"suite-name\">name2</a>\n"
+ " </li>\n"
+ " <li class=\"suite-title\">\n"
+ " <a href=\"https://www.sitename.org/profile/name3/fl/suite\" title=\"name3\"class=\"suite-name\">name3</a>\n"
+ " </li>\n"
+ " </ul>\n\n\n"
+ " <h3 class=\\\"suite-title\\\">author</h3>\\s+<ul class=\\\"suite-title-list\\\">\\s+<li class=\\\"suite-title\\\">\\s+<a href.*\\\">(.*?)</a>\n\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}