import Foundation
let pattern = #"<h3 class=\"suite-title\">author</h3>\s+<ul class=\"suite-title-list\">\s+<li class=\"suite-title\">\s+<a href.*\">(.*?)</a>"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Hi
I have the following code. How do I separate the `name2` and `name3` from the `"suite-title">author</h3>` field with regex?
<li class="suite-item">
<h3 class="suite-title">thinker</h3>
<ul class="suite-title-list">
<li class="suite-title">
<a href="https://www.sitename.org/profile/name1/fl/suite" title="name1"class="suite-name">name1</a>
</li>
</ul>
</li>
<li class="suite-item">
<h3 class="suite-title">author</h3>
<ul class="suite-title-list">
<li class="suite-title">
<a href="https://www.sitename.org/profile/name2/fl/suite" title="name2"class="suite-name">name2</a>
</li>
<li class="suite-title">
<a href="https://www.sitename.org/profile/name3/fl/suite" title="name3"class="suite-name">name3</a>
</li>
</ul>
<h3 class=\"suite-title\">author</h3>\s+<ul class=\"suite-title-list\">\s+<li class=\"suite-title\">\s+<a href.*\">(.*?)</a>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)