// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)<h3 class=\"suite-title\">author</h3>\s+<ul class=\"suite-title-list\">\s+<li class=\"suite-title\">\s+<a href.*\">(.*?)</a>"#).unwrap();
let string = "Hi
I have the following code. How do I separate the `name2` and `name3` from the `\"suite-title\">author</h3>` field with regex?
<li class=\"suite-item\">
<h3 class=\"suite-title\">thinker</h3>
<ul class=\"suite-title-list\">
<li class=\"suite-title\">
<a href=\"https://www.sitename.org/profile/name1/fl/suite\" title=\"name1\"class=\"suite-name\">name1</a>
</li>
</ul>
</li>
<li class=\"suite-item\">
<h3 class=\"suite-title\">author</h3>
<ul class=\"suite-title-list\">
<li class=\"suite-title\">
<a href=\"https://www.sitename.org/profile/name2/fl/suite\" title=\"name2\"class=\"suite-name\">name2</a>
</li>
<li class=\"suite-title\">
<a href=\"https://www.sitename.org/profile/name3/fl/suite\" title=\"name3\"class=\"suite-name\">name3</a>
</li>
</ul>
<h3 class=\\\"suite-title\\\">author</h3>\\s+<ul class=\\\"suite-title-list\\\">\\s+<li class=\\\"suite-title\\\">\\s+<a href.*\\\">(.*?)</a>
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}