using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:tcp|ip|udp|pop|smpt|t?ftp|https?):\/\/(?:[a-zA-Z]+:[a-zA-Z\.=%#\-_&]+@)?(?![\.\-])(?:(?:[a-z-A-Z0-9\-](?!\-{2,})){1,63}\.(?:[a-zA-Z0-9\-](?!\-{2,})){1,63}\.?(?:[a-zA-Z0-9\-](?!\-{2,})){1,63}?\.?(?:[a-zA-Z0-9\-](?!\-{2,})){1,63}?)(?:\:(?:[0-9]{1,4}|[0-6][0-5]{1,2}[0-3][0-5]))?(?:\/|\/(?!\/)(?:[a-zA-Z0-9\-\/](?!\/{2,}))+)?(?:\?(?:(?:[a-zA-Z0-9\-\_\=\&\:\+]|%(?:[A-Z0-9]){2})(?!%{2,}|={2,}|&{2,}|\+{2,}))+)(?:#(?:(?:[a-zA-Z0-9\=\-\_\:\~]|%[A-Z0-9]{2})(?!\={2,}|~{2,}|:{2,}|\-{2,}|\_{2,}))*)?$";
string input = @"https://user:pass@www.google.com/some/path/with/query?a=%A3+xd&ab#aa";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}