import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:tcp|ip|udp|pop|smpt|t?ftp|https?):\\/\\/(?:[a-zA-Z]+:[a-zA-Z\\.=%#\\-_&]+@)?(?![\\.\\-])(?:(?:[a-z-A-Z0-9\\-](?!\\-{2,})){1,63}\\.(?:[a-zA-Z0-9\\-](?!\\-{2,})){1,63}\\.?(?:[a-zA-Z0-9\\-](?!\\-{2,})){1,63}?\\.?(?:[a-zA-Z0-9\\-](?!\\-{2,})){1,63}?)(?:\\:(?:[0-9]{1,4}|[0-6][0-5]{1,2}[0-3][0-5]))?(?:\\/|\\/(?!\\/)(?:[a-zA-Z0-9\\-\\/](?!\\/{2,}))+)?(?:\\?(?:(?:[a-zA-Z0-9\\-\\_\\=\\&\\:\\+]|%(?:[A-Z0-9]){2})(?!%{2,}|={2,}|&{2,}|\\+{2,}))+)(?:#(?:(?:[a-zA-Z0-9\\=\\-\\_\\:\\~]|%[A-Z0-9]{2})(?!\\={2,}|~{2,}|:{2,}|\\-{2,}|\\_{2,}))*)?$";
final String string = "https://user:pass@www.google.com/some/path/with/query?a=%A3+xd&ab#aa";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}