use strict;
my $str = 'https://user:pass@www.google.com/some/path/with/query?a=%A3+xd&ab#aa';
my $regex = qr/^(?:tcp|ip|udp|pop|smpt|t?ftp|https?):\/\/(?:[a-zA-Z]+:[a-zA-Z\.=%#\-_&]+@)?(?![\.\-])(?:(?:[a-z-A-Z0-9\-](?!\-{2,})){1,63}\.(?:[a-zA-Z0-9\-](?!\-{2,})){1,63}\.?(?:[a-zA-Z0-9\-](?!\-{2,})){1,63}?\.?(?:[a-zA-Z0-9\-](?!\-{2,})){1,63}?)(?:\:(?:[0-9]{1,4}|[0-6][0-5]{1,2}[0-3][0-5]))?(?:\/|\/(?!\/)(?:[a-zA-Z0-9\-\/](?!\/{2,}))+)?(?:\?(?:(?:[a-zA-Z0-9\-\_\=\&\:\+]|%(?:[A-Z0-9]){2})(?!%{2,}|={2,}|&{2,}|\+{2,}))+)(?:#(?:(?:[a-zA-Z0-9\=\-\_\:\~]|%[A-Z0-9]{2})(?!\={2,}|~{2,}|:{2,}|\-{2,}|\_{2,}))*)?$/p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}