const regex = /^(?:tcp|ip|udp|pop|smpt|t?ftp|https?):\/\/(?:[a-zA-Z]+:[a-zA-Z\.=%#\-_&]+@)?(?![\.\-])(?:(?:[a-z-A-Z0-9\-](?!\-{2,})){1,63}\.(?:[a-zA-Z0-9\-](?!\-{2,})){1,63}\.?(?:[a-zA-Z0-9\-](?!\-{2,})){1,63}?\.?(?:[a-zA-Z0-9\-](?!\-{2,})){1,63}?)(?:\:(?:[0-9]{1,4}|[0-6][0-5]{1,2}[0-3][0-5]))?(?:\/|\/(?!\/)(?:[a-zA-Z0-9\-\/](?!\/{2,}))+)?(?:\?(?:(?:[a-zA-Z0-9\-\_\=\&\:\+]|%(?:[A-Z0-9]){2})(?!%{2,}|={2,}|&{2,}|\+{2,}))+)(?:#(?:(?:[a-zA-Z0-9\=\-\_\:\~]|%[A-Z0-9]{2})(?!\={2,}|~{2,}|:{2,}|\-{2,}|\_{2,}))*)?$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:tcp|ip|udp|pop|smpt|t?ftp|https?):\\\/\\\/(?:[a-zA-Z]+:[a-zA-Z\\.=%#\\-_&]+@)?(?![\\.\\-])(?:(?:[a-z-A-Z0-9\\-](?!\\-{2,})){1,63}\\.(?:[a-zA-Z0-9\\-](?!\\-{2,})){1,63}\\.?(?:[a-zA-Z0-9\\-](?!\\-{2,})){1,63}?\\.?(?:[a-zA-Z0-9\\-](?!\\-{2,})){1,63}?)(?:\\:(?:[0-9]{1,4}|[0-6][0-5]{1,2}[0-3][0-5]))?(?:\\\/|\\\/(?!\\\/)(?:[a-zA-Z0-9\\-\\\/](?!\\\/{2,}))+)?(?:\\?(?:(?:[a-zA-Z0-9\\-\\_\\=\\&\\:\\+]|%(?:[A-Z0-9]){2})(?!%{2,}|={2,}|&{2,}|\\+{2,}))+)(?:#(?:(?:[a-zA-Z0-9\\=\\-\\_\\:\\~]|%[A-Z0-9]{2})(?!\\={2,}|~{2,}|:{2,}|\\-{2,}|\\_{2,}))*)?$', '')
const str = `https://user:pass@www.google.com/some/path/with/query?a=%A3+xd&ab#aa`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}