#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "("((?:[^"\\])*(?:\\\")*)*")"
Local $sString = ""This is a test \" with an escaped quote"" & @CRLF & _
"this is some text outside the quotes" & @CRLF & _
""this is another test"" & @CRLF & _
"" & @CRLF & _
""\""" & @CRLF & _
"" & @CRLF & _
""\"\""" & @CRLF & _
"" & @CRLF & _
""sadasd\"\"3456""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")