$re = '/("((?:[^"\\\\])*(?:\\\\\")*)*")/';
$str = '"This is a test \\" with an escaped quote"
this is some text outside the quotes
"this is another test"
"\\""
"\\"\\""
"sadasd\\"\\"3456"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);