// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"("((?:[^"\\])*(?:\\\")*)*")"#).unwrap();
let string = "\"This is a test \\\" with an escaped quote\"
this is some text outside the quotes
\"this is another test\"
\"\\\"\"
\"\\\"\\\"\"
\"sadasd\\\"\\\"3456\"";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}