re = /("((?:[^"\\])*(?:\\\")*)*")/
str = '"This is a test \\" with an escaped quote"
this is some text outside the quotes
"this is another test"
"\\""
"\\"\\""
"sadasd\\"\\"3456"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end