package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`("((?:[^"\\])*(?:\\\")*)*")`)
var str = `"This is a test \" with an escaped quote"
this is some text outside the quotes
"this is another test"
"\""
"\"\""
"sadasd\"\"3456"`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}