using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^https?:\/\/((?:[a-z0-9](?:[a-z0-9-]{0,61}[a-z0-9])?\.)+[a-z0-9][a-z0-9-]{0,61}[a-z0-9])\/@([a-zA-Z0-9\_]+)\/(\d+)$";
string input = @"https://social.fossdle.org/@todbot@mastodon.social/109497770346696964
https://social.fossdle.org/@cogdog/109491626110489685
https://mastodon.ie/@lauramcdonnell/109496294552737622
https://twitter.com/ds106dc/status/1601902285226971137
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}