use strict;
my $str = 'https://social.fossdle.org/@todbot@mastodon.social/109497770346696964
https://social.fossdle.org/@cogdog/109491626110489685
https://mastodon.ie/@lauramcdonnell/109496294552737622
https://twitter.com/ds106dc/status/1601902285226971137
';
my $regex = qr/^https?:\/\/((?:[a-z0-9](?:[a-z0-9-]{0,61}[a-z0-9])?\.)+[a-z0-9][a-z0-9-]{0,61}[a-z0-9])\/@([a-zA-Z0-9\_]+)\/(\d+)$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}