import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^https?:\\/\\/((?:[a-z0-9](?:[a-z0-9-]{0,61}[a-z0-9])?\\.)+[a-z0-9][a-z0-9-]{0,61}[a-z0-9])\\/@([a-zA-Z0-9\\_]+)\\/(\\d+)$";
final String string = "https://social.fossdle.org/@todbot@mastodon.social/109497770346696964\n"
+ "https://social.fossdle.org/@cogdog/109491626110489685\n"
+ "https://mastodon.ie/@lauramcdonnell/109496294552737622\n"
+ "https://twitter.com/ds106dc/status/1601902285226971137\n\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}