import re
regex = re.compile(r"^https?:\/\/((?:[a-z0-9](?:[a-z0-9-]{0,61}[a-z0-9])?\.)+[a-z0-9][a-z0-9-]{0,61}[a-z0-9])\/@([a-zA-Z0-9\_]+)\/(\d+)$", flags=re.MULTILINE)
test_str = ("https://social.fossdle.org/@todbot@mastodon.social/109497770346696964\n"
"https://social.fossdle.org/@cogdog/109491626110489685\n"
"https://mastodon.ie/@lauramcdonnell/109496294552737622\n"
"https://twitter.com/ds106dc/status/1601902285226971137\n\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")