package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\p{L}[\p{L}\p{M}\h().'&-]*$`)
var str = `first-second
first second
first'second
first & second
first&second
first(second)
first (second)
first-second-third
first second third
first second third(fourth)
first-second-third(fourth)
word Castaٌeda
Word Word (Word)
Alfonso Lista (Potia)
Bacolod-Kalawi (Bacolod-Grande)
Balindong (Watu)
President Manuel A. Roxas
Enrique B. Magalona (Saravia)
Bacolod-Kalawi (Bacolod-Grande)
Datu Blah T. Sinsuat
Don Victoriano Chiongbian (Don Mariano Marcos)
Bulalacao (San Pedro)
Hinoba-an (Asia)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}