import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\p{L}[\\p{L}\\p{M}\\h().'&-]*$";
final String string = "first-second\n"
+ "first second\n"
+ "first'second\n"
+ "first & second\n"
+ "first&second\n"
+ "first(second)\n"
+ "first (second)\n"
+ "first-second-third\n"
+ "first second third\n"
+ "first second third(fourth)\n"
+ "first-second-third(fourth)\n"
+ "word Castaٌeda\n"
+ "Word Word (Word)\n\n"
+ "Alfonso Lista (Potia)\n"
+ "Bacolod-Kalawi (Bacolod-Grande)\n"
+ "Balindong (Watu)\n"
+ "President Manuel A. Roxas\n"
+ "Enrique B. Magalona (Saravia)\n"
+ "Bacolod-Kalawi (Bacolod-Grande)\n"
+ "Datu Blah T. Sinsuat\n"
+ "Don Victoriano Chiongbian (Don Mariano Marcos)\n"
+ "Bulalacao (San Pedro)\n"
+ "Hinoba-an (Asia)";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.UNICODE_CASE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}