import Foundation
// WARNING: You included a flag that Swift doesn't support: u
// When this flag is set, it makes the pattern and subject strings to be treated as unicode.
// Swift already treats the pattern and subject strings as unicode by default, so including this flag is redundant.
let pattern = #"^\p{L}[\p{L}\p{M}\h().'&-]*$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
first-second
first second
first'second
first & second
first&second
first(second)
first (second)
first-second-third
first second third
first second third(fourth)
first-second-third(fourth)
word Castaٌeda
Word Word (Word)
Alfonso Lista (Potia)
Bacolod-Kalawi (Bacolod-Grande)
Balindong (Watu)
President Manuel A. Roxas
Enrique B. Magalona (Saravia)
Bacolod-Kalawi (Bacolod-Grande)
Datu Blah T. Sinsuat
Don Victoriano Chiongbian (Don Mariano Marcos)
Bulalacao (San Pedro)
Hinoba-an (Asia)
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)