use strict;
my $str = 'first-second
first second
first\'second
first & second
first&second
first(second)
first (second)
first-second-third
first second third
first second third(fourth)
first-second-third(fourth)
word Castaٌeda
Word Word (Word)
Alfonso Lista (Potia)
Bacolod-Kalawi (Bacolod-Grande)
Balindong (Watu)
President Manuel A. Roxas
Enrique B. Magalona (Saravia)
Bacolod-Kalawi (Bacolod-Grande)
Datu Blah T. Sinsuat
Don Victoriano Chiongbian (Don Mariano Marcos)
Bulalacao (San Pedro)
Hinoba-an (Asia)';
my $regex = qr/^\p{L}[\p{L}\p{M}\h().'&-]*$/mup;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}