import Foundation
let pattern = #"^\s*\((.+?)\)(?: .*)$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
(RA-B) RA-B三室两卫
(RA-B(NOC)) RA-B-NOC三室两卫
(RA-A) RA-A三室两卫
(RA-A(T)) RA-A(T)三室两卫
(more wicked) example
(WTF CODE CONTAINS WHITESPACES!) still it works
This (violates) the rule.
(Needs a whitespace)after the parenthesis.
((Nested) parentheses) causes unexpected results.
(Badly (paired) parentheses ain't my fault.
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)