import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "A\\S+\\s([^:(]*)(?=:|\\s\\()";
final String string = "A1 muscle pain: immunotherapy'\n"
+ "A2B_45 muscle pain: topical medicine e.g. ....'\n"
+ "A2_45 muscle pain (pain): topical medicine e.g. ....'";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}