const regex = new RegExp('A\\S+\\s([^:(]*)(?=:|\\s\\()', 'gm')
const str = `A1 muscle pain: immunotherapy'
A2B_45 muscle pain: topical medicine e.g. ....'
A2_45 muscle pain (pain): topical medicine e.g. ....'`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}