re = /A\S+\s([^:(]*)(?=:|\s\()/m
str = 'A1 muscle pain: immunotherapy\'
A2B_45 muscle pain: topical medicine e.g. ....\'
A2_45 muscle pain (pain): topical medicine e.g. ....\''
# Print the match result
str.scan(re) do |match|
puts match.to_s
end