import re
regex = re.compile(r"A\S+\s([^:(]*)(?=:|\s\()", flags=re.MULTILINE)
test_str = ("A1 muscle pain: immunotherapy'\n"
"A2B_45 muscle pain: topical medicine e.g. ....'\n"
"A2_45 muscle pain (pain): topical medicine e.g. ....'")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")