# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/<img\s+
(?=[^>]*\balt="(?<alt>[^>]*?)")? # optional alt attribute
(?=[^>]*\bclass="(?<class>[^>]*?)")? # optional class attribute
(?=[^>]*\bsrc="(?<src>[^>]*?)") # src attribute
[^>]*\\/>/{.${class}}/gx;t' <<< "<img src=\"image.png\" alt=\"test\" style=\"zoom:55%;\" />
<img class=\"big\" src=\"image2.png\" />
<img alt=\"test\" src=\"image.png\" style=\"zoom:55%;\" />
<img src=\"image.png\" class=\"small\" style=\"zoom:55%;\" alt=\"test\" />
<img src=\"image.png\" alt=\"test\" style=\"zoom:55%;\" />
<img src=\"image.png\"
alt=\"test\"
style=\"zoom:55%;\" />"