using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<img\s+
(?=[^>]*\balt=""(?<alt>[^>]*?)"")? # optional alt attribute
(?=[^>]*\bclass=""(?<class>[^>]*?)"")? # optional class attribute
(?=[^>]*\bsrc=""(?<src>[^>]*?)"") # src attribute
[^>]*\/>";
string substitution = @"{.${class}}";
string input = @"<img src=""image.png"" alt=""test"" style=""zoom:55%;"" />
<img class=""big"" src=""image2.png"" />
<img alt=""test"" src=""image.png"" style=""zoom:55%;"" />
<img src=""image.png"" class=""small"" style=""zoom:55%;"" alt=""test"" />
<img src=""image.png"" alt=""test"" style=""zoom:55%;"" />
<img src=""image.png""
alt=""test""
style=""zoom:55%;"" />";
RegexOptions options = RegexOptions.IgnorePatternWhitespace;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}