# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"""
<img\s+
(?=[^>]*\balt="(?<alt>[^>]*?)")? # optional alt attribute
(?=[^>]*\bclass="(?<class>[^>]*?)")? # optional class attribute
(?=[^>]*\bsrc="(?<src>[^>]*?)") # src attribute
[^>]*\/>
"""
test_str = ("<img src=\"image.png\" alt=\"test\" style=\"zoom:55%;\" />\n"
"<img class=\"big\" src=\"image2.png\" />\n"
"<img alt=\"test\" src=\"image.png\" style=\"zoom:55%;\" />\n"
"<img src=\"image.png\" class=\"small\" style=\"zoom:55%;\" alt=\"test\" />\n"
"<img src=\"image.png\" alt=\"test\" style=\"zoom:55%;\" />\n"
"<img src=\"image.png\"\n"
" alt=\"test\"\n"
" style=\"zoom:55%;\" />")
subst = "{.${class}}"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.VERBOSE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.