import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<img\\s+\n"
+ "(?=[^>]*\\balt=\"(?<alt>[^>]*?)\")? # optional alt attribute\n"
+ "(?=[^>]*\\bclass=\"(?<class>[^>]*?)\")? # optional class attribute\n"
+ "(?=[^>]*\\bsrc=\"(?<src>[^>]*?)\") # src attribute\n"
+ "[^>]*\\/>";
final String string = "<img src=\"image.png\" alt=\"test\" style=\"zoom:55%;\" />\n"
+ "<img class=\"big\" src=\"image2.png\" />\n"
+ "<img alt=\"test\" src=\"image.png\" style=\"zoom:55%;\" />\n"
+ "<img src=\"image.png\" class=\"small\" style=\"zoom:55%;\" alt=\"test\" />\n"
+ "<img src=\"image.png\" alt=\"test\" style=\"zoom:55%;\" />\n"
+ "<img src=\"image.png\"\n"
+ " alt=\"test\"\n"
+ " style=\"zoom:55%;\" />";
final String subst = "{.${class}}";
final Pattern pattern = Pattern.compile(regex, Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}