#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:ISBN(?:-13)?:? )?((?=[0-9]{13}$|(?=(?:[0-9]+[- ]){1,4})[- 0-9]{14,17}$)97[89][- ]?[0-9]{1,5}[- ]?[0-9]+[- ]?[0-9]+[- ]?[0-9])$"
Local $sString = "ISBN: 9 788205 478022" & @CRLF & _
"ISBN: 9788205478022" & @CRLF & _
"ISBN: 978 82 05 47802 2" & @CRLF & _
"ISBN: 978-82-05-47802-2" & @CRLF & _
"9 788205 478022" & @CRLF & _
"9788205478022" & @CRLF & _
"978 82 05 47802 2" & @CRLF & _
"978-82-05-47802-2"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")