$re = '/^(?:ISBN(?:-13)?:? )?((?=[0-9]{13}$|(?=(?:[0-9]+[- ]){1,4})[- 0-9]{14,17}$)97[89][- ]?[0-9]{1,5}[- ]?[0-9]+[- ]?[0-9]+[- ]?[0-9])$/m';
$str = 'ISBN: 9 788205 478022
ISBN: 9788205478022
ISBN: 978 82 05 47802 2
ISBN: 978-82-05-47802-2
9 788205 478022
9788205478022
978 82 05 47802 2
978-82-05-47802-2';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);