re = /^(?:ISBN(?:-13)?:? )?((?=[0-9]{13}$|(?=(?:[0-9]+[- ]){1,4})[- 0-9]{14,17}$)97[89][- ]?[0-9]{1,5}[- ]?[0-9]+[- ]?[0-9]+[- ]?[0-9])$/m
str = 'ISBN: 9 788205 478022
ISBN: 9788205478022
ISBN: 978 82 05 47802 2
ISBN: 978-82-05-47802-2
9 788205 478022
9788205478022
978 82 05 47802 2
978-82-05-47802-2'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end