use strict;
my $str = 'ISBN: 9 788205 478022
ISBN: 9788205478022
ISBN: 978 82 05 47802 2
ISBN: 978-82-05-47802-2
9 788205 478022
9788205478022
978 82 05 47802 2
978-82-05-47802-2';
my $regex = qr/^(?:ISBN(?:-13)?:? )?((?=[0-9]{13}$|(?=(?:[0-9]+[- ]){1,4})[- 0-9]{14,17}$)97[89][- ]?[0-9]{1,5}[- ]?[0-9]+[- ]?[0-9]+[- ]?[0-9])$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}