const regex = /^(?:ISBN(?:-13)?:? )?((?=[0-9]{13}$|(?=(?:[0-9]+[- ]){1,4})[- 0-9]{14,17}$)97[89][- ]?[0-9]{1,5}[- ]?[0-9]+[- ]?[0-9]+[- ]?[0-9])$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:ISBN(?:-13)?:? )?((?=[0-9]{13}$|(?=(?:[0-9]+[- ]){1,4})[- 0-9]{14,17}$)97[89][- ]?[0-9]{1,5}[- ]?[0-9]+[- ]?[0-9]+[- ]?[0-9])$', 'gm')
const str = `ISBN: 9 788205 478022
ISBN: 9788205478022
ISBN: 978 82 05 47802 2
ISBN: 978-82-05-47802-2
9 788205 478022
9788205478022
978 82 05 47802 2
978-82-05-47802-2`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}