using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b[A-Z]{1,2}\d{1,2}\s{0,}[A-Z]{3}\b";
string input = @"My 2.2L car (L4 MUP) is a Range Rover Evoque and was registered in 2012
Who is the owner of car AB12 CDE?
S44 SHD is an example of a personalised reg plate
My password is ALL4ONE or 14ALL but my car is AL4ONE
Your Name is RAJ SOOKRAH
GHESYT5 GK66 DMO 46703h ";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}