package main
import (
    "regexp"
    "fmt"
)
func main() {
    var re = regexp.MustCompile(`(?m)\b[A-Z]{1,2}\d{1,2}\s{0,}[A-Z]{3}\b`)
    var str = `My 2.2L car (L4 MUP) is a Range Rover Evoque and was registered in 2012
Who is the owner of car AB12 CDE?
S44 SHD is an example of a personalised reg plate
My password is ALL4ONE or 14ALL but my car is AL4ONE
Your Name is RAJ SOOKRAH
GHESYT5 GK66 DMO 46703h  `
    
    for i, match := range re.FindAllString(str, -1) {
        fmt.Println(match, "found at index", i)
    }
}