import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b[A-Z]{1,2}\\d{1,2}\\s{0,}[A-Z]{3}\\b";
final String string = "My 2.2L car (L4 MUP) is a Range Rover Evoque and was registered in 2012\n"
+ "Who is the owner of car AB12 CDE?\n"
+ "S44 SHD is an example of a personalised reg plate\n"
+ "My password is ALL4ONE or 14ALL but my car is AL4ONE\n"
+ "Your Name is RAJ SOOKRAH\n"
+ "GHESYT5 GK66 DMO 46703h ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}