import re
regex = re.compile(r"\b[A-Z]{1,2}\d{1,2}\s{0,}[A-Z]{3}\b", flags=re.MULTILINE)
test_str = ("My 2.2L car (L4 MUP) is a Range Rover Evoque and was registered in 2012\n"
"Who is the owner of car AB12 CDE?\n"
"S44 SHD is an example of a personalised reg plate\n"
"My password is ALL4ONE or 14ALL but my car is AL4ONE\n"
"Your Name is RAJ SOOKRAH\n"
"GHESYT5 GK66 DMO 46703h ")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")