#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^wp-content\/uploads\/(?!(2021\/06||2021\/07)\/).+$"
Local $sString = "wp-content/uploads/2021/06/list-block-3.svg" & @CRLF & _
"wp-content/uploads/2021/06/list-block-3.svg" & @CRLF & _
"wp-content/uploads/2021/06/list-block-3.svg" & @CRLF & _
"wp-content/uploads/2021/07/list-block-3.svg" & @CRLF & _
"wp-content/uploads/may/05/list-block-3.svg" & @CRLF & _
"wp-content/uploads/2021/05/list-block-3.svg" & @CRLF & _
"wp-content/uploads/2020/02/list-block-3.svg"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")