import Foundation
let pattern = #"^wp-content\/uploads\/(?!(2021\/06||2021\/07)\/).+$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
wp-content/uploads/2021/06/list-block-3.svg
wp-content/uploads/2021/06/list-block-3.svg
wp-content/uploads/2021/06/list-block-3.svg
wp-content/uploads/2021/07/list-block-3.svg
wp-content/uploads/may/05/list-block-3.svg
wp-content/uploads/2021/05/list-block-3.svg
wp-content/uploads/2020/02/list-block-3.svg
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)