import re
regex = re.compile(r"^wp-content\/uploads\/(?!(2021\/06||2021\/07)\/).+$", flags=re.MULTILINE)
test_str = ("wp-content/uploads/2021/06/list-block-3.svg\n"
"wp-content/uploads/2021/06/list-block-3.svg\n"
"wp-content/uploads/2021/06/list-block-3.svg\n"
"wp-content/uploads/2021/07/list-block-3.svg\n"
"wp-content/uploads/may/05/list-block-3.svg\n"
"wp-content/uploads/2021/05/list-block-3.svg\n"
"wp-content/uploads/2020/02/list-block-3.svg")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")