using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^wp-content\/uploads\/(?!(2021\/06||2021\/07)\/).+$";
string input = @"wp-content/uploads/2021/06/list-block-3.svg
wp-content/uploads/2021/06/list-block-3.svg
wp-content/uploads/2021/06/list-block-3.svg
wp-content/uploads/2021/07/list-block-3.svg
wp-content/uploads/may/05/list-block-3.svg
wp-content/uploads/2021/05/list-block-3.svg
wp-content/uploads/2020/02/list-block-3.svg";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}