#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = ".*=(.*)=.*|(.*)=.*"
Local $sString = ""I have candy='4' and ice cream = 'vanilla'"" & @CRLF & _
"I have candy='4' and ice cream = 'vanilla' and house='big'" & @CRLF & _
"Regex is fun" & @CRLF & _
"Regex is beauty =" & @CRLF & _
"Regex is awesome = test test test" & @CRLF & _
""
Local $sSubst = "$1$2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)