$re = '/.*=(.*)=.*|(.*)=.*/';
$str = '"I have candy=\'4\' and ice cream = \'vanilla\'"
I have candy=\'4\' and ice cream = \'vanilla\' and house=\'big\'
Regex is fun
Regex is beauty =
Regex is awesome = test test test
';
$subst = "$1$2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;